User’s Guide : Global Options : The Options Menu
  
The Options Menu
 
General Options
Startup
Environment Appearance
Window Behavior
Keyboard
Snapshots
Fonts
Command Capture
Frequency Conversion
Series Auto Labels
Auto-series
History in Labels
Auto-series
Alpha Truncation
Spreadsheet Layout
Spreadsheet Data Display
Table Options
Workfile Storage Defaults
Database Storage Defaults
Date Representation
Estimation Defaults
Programs
PDF Page Settings
LaTex Settings
External Program Interface
Network Proxy Server
File Locations
Advanced System Options
Memory Allocation
Multi-Processor Use
Graphics Defaults
Database Registry
Cloud Management
EViews Auto-Update from Web
The Options menu in the main toolbar allows you to define the default behavior for many of the operations in EViews. Most options are found within the General Options... and Graphics Defaults... menu items.
General Options
When you click the General Options... menu item, EViews brings up the Global Options dialog. This dialog is broken up into many sections which are accessible using the tree on the left-hand side of the dialog. We discuss briefly the options within each of these sections. In some cases, additional detail is provided in the corresponding sections of the manual.
Startup
The startup section controls the display of the startup page, and the handling of messages.
Environment Appearance
EViews provides a number of color themes to modify the appearance of your EViews environment.
In the Window colors groupbox, you may select from a variety of basic themes, including Light Blue, Silver, and EViews Classic. You can completely customize the color by selecting Custom.
You can let the background and status bar follow this color theme, or choose a different color from the Background & status bar dropdown.
Not surprisingly, the Caption bar & borders dropdown may be used to choose the visual style of your caption bar and borders. The Default setting is for EViews to draw the caption bars and borders using colors in a style to match your operating system (either Windows XP or Windows Vista/Windows 7). You may instead choose EViews rounded or Vista style to have EViews choose a style independent of your operating system. If you have modified your operating system settings for window borders and text, and wish to have the operating system draw the caption and borders, you should select Operating system drawn.
Most windows in EViews have a row of buttons along the top, called the button bar. To hide these buttons on all windows, uncheck Display button bars on the top right of the dialog.
Window Behavior
The Window behavior page controls the display characteristics of various types of EViews output.
The settings are divided into broad groupings:
The Warn On Close section in the upper left-hand corner of the dialog instructs EViews to provide a warning message when you close an untitled object. You may choose to set warnings for various object types. By default, EViews warns you that closing an unnamed object without naming it will cause the object to be deleted. Along with the warning, you will be given an opportunity to name the object. If you turn the warning off, closing an untitled window will automatically delete the object.
Allow Only One Untitled specifies, for each object type, whether to allow multiple untitled objects to be opened at the same time. If only one is allowed, creating a new untitled object will cause any existing untitled object of that type to be deleted automatically. Setting EViews to allow only one untitled object reduces the number of windows that you will see on your desktop.
If you elect to allow only one untitled object, we strongly recommend that you select Warn on Close. With this option set, you will be given the opportunity to name and save an existing untitled object, otherwise the object will simply be deleted.
File open on double click controls the whether to use an existing EViews session or to launch an additional session when opening an EViews associated file. Selecting Open in existing EViews session (when possible) means that when using Windows to open an EViews file, say by double clicking, selecting an EViews file from the start menu, or opening as an email attachment, the file will open in an already running copy of EViews, if available.
Run program on EViews startup determines the behavior of EViews when launching the program by double clicking on a program file in a Windows directory. By default EViews, will open and run the program when you double click. Unselect this checkbox to prevent the program from being run automatically. Note that if EViews is already running when the program file is double-clicked, EViews will only open the file, regardless of this setting. This setting only applies when a new instance of EViews is launched to handle the program file.
Keyboard
The Keyboard page offers options for setting focus and for smart editing.
Keyboard Focus controls where the keyboard cursor is placed when you change views or windows. As the label suggests, when you select Command Window, the keyboard focus will go to the command window following a change of view. This setting is most useful if you primarily use EViews via the command line. Choosing Active Window will cause the focus to go to the active window following a change of view. You will find this setting useful if you wish to use keystrokes to navigate between and to select items in various windows. Note that whatever the default setting, you may always change the keyboard focus by clicking in the command window, or by clicking in the active window.
Smart edit allows you to turn off the automatic pop-up that displays possible entries in edit fields. If Both automatically and on demand is selected, the list will be presented, after a pause in typing, from within most edit fields except the command window. If Only on demand via Ctl+L is selected, you can use the keystroke, as always, to bring up the list of entries.
You may change the delay used when automatic pop-ups are enabled, by entering the desired number of milliseconds in the appropriate edit field.
Snapshots
By default, EViews 10 will automatically check for changes every five minutes and then save a snapshot only if changes are detected. These automatic snapshots will be deleted when the workfile is closed.
You can change the default snapshot settings in the General Options/Snapshots dialog.
Snapshots are usually saved into a hidden folder in the same directory as the main workfile. However, you can group all the snapshot folders into the same location by specifying a common snapshots folder.
For automatic snapshots, you can change how often EViews performs the check, and whether snapshots should be kept if no changes are detected. You can also tell EViews not to discard automatic snapshots when the workfile is closed and to limit how many auto snapshots should be kept. Setting this value to zero will allow unlimited auto snapshots.
Finally, you can also set a time limit (in seconds) for an automatic snapshot to operate for each workfile. Because workfiles can sometimes take a long time to load or save, auto snapshots will be skipped for any workfile that takes longer than 10 seconds to load or save. This time restriction prevents auto snapshots from locking up EViews for too long while running in the background. Any workfile that takes too long to open or save will then optionally prompt you to exclude it from any further automatic snapshots. You can change this time limit to zero to remove all time restrictions.
To prevent EViews from prompting you with each workfile that takes too long, you can also uncheck the Prompt on each file… checkbox.
Fonts
The Fonts section allows you to change the default font styles and sizes for various sets of windows and objects. Select the type of object for which you want to change the font from the dropdown at the top of the dialog and modify the font settings below. For example, to set the default font face and size to be used in table objects and table views of objects, select Spreadsheets & Table defaults and modify the settings below the dropdown.
Command Capture
The Command Capture setting determines whether to echo the contents of the command capture to the command window. Choosing Send command capture to Command Capture Window and to Command Window allows the contents of the command capture to be displayed in both windows. Choosing Send command capture to Command Capture Window Only puts the contents of the command capture in the command capture window.
Frequency Conversion
The Frequency conversion dialog within the Series and Alphas section allows you to set the default frequency conversion methods for both up and down conversion, and the default method of displaying dates.
The default frequency conversion method tells EViews how to convert data when you move data to lower or higher frequency workfiles. The frequency conversion methods and use of default settings are discussed in detail in “Reading EViews Data using Other Applications”.
Series Auto Labels
You may elect to have EViews keep a history of the commands that created or modified a series as part of the series label. You can choose to turn this option on or off in the History in labels dialog within the Series and Alphas section.
Note that the series label may be viewed by selecting View/Label in a series window, or at the top of a series spreadsheet if the spreadsheet defaults are set to display labels (“Spreadsheet Layout”).
Auto-series
In the Auto-series page under Series and Alphas, the Alpha-series in stats option lets you control whether EViews simply ignores evaluation errors in auto-series when performing statistical analysis, or reports an error. Auto-series are functions or expressions of existing workfile series that may be used in a statistical procedure.
For example, the auto-series LOG(X) may be used as a regressor in an equation object, or as one of the series used in a cointegration test. When the option is set to Report evaluation errors in statistical views and procs, if the auto-series cannot be evaluated for any observation (for example, any observation where X is negative when using LOG(X)), EViews will error and, possibly, stop computation of the statistical procedure. If the option is set to Treat evaluation errors as NAs, any observation that cannot be evaluated will simply be converted into an NA and the statistical computation will continue, usually ignoring that observation.
History in Labels
You may set the default for whether or not to save the command history in the series labels.
Auto-series
You may choose whether or not to treat evaluation errors in auto-series as missing (NA) values, or whether to report an error when an evaluation error is encountered.
Alpha Truncation
Note that EViews alpha series automatically resize as needed, up to the truncation length.
To modify the alpha series truncation length, select Alpha Truncation from the Series and Alphas section, and enter the desired length. Subsequent alpha series creation and assignment will use the new truncation length.
You should bear in mind that the strings in EViews alpha series are of fixed length, so that the size of each observation is equal to the length of the longest string. If you have a series with all short strings, with the exception of one very long string, the memory taken up by the series will be the number of observations times the longest string size.
The maximum string length is 1,000 characters.
Spreadsheet Layout
The options in the Layout dialog within the Spreadsheets section control the default spreadsheet view settings of series, group, and table objects. The defaults are set using these option settings when the object is first created.
In the Series spreadsheets portion of the dialog, you may set the display format and choose to display the spreadsheet in one or multiple columns, with or without object labels and header information. In addition, you may choose to have edit mode turned on or off by default.
Below this section are the Group spreadsheet options for sample filtering, transposed display, and edit mode.
Frozen tables allows you to modify whether edit mode is on or off by default.
You may set the Spreadsheet display order to ascending or descending from the dropdown in the upper-right corner of the dialog.
Spreadsheet Data Display
The Data display dialog within the Spreadsheets section provides other default settings that apply to new numeric and text spreadsheets.
The Data displayed as dropdown menu, in the Numeric display portion of the dialog, determines what type of data the rest of the section refers to. You can specify a display format for each of the transform types specified in the dropdown menu (Level & Difference, % Change & Log Dif, or Logarithm). For instance, if you select Level & Difference, you can alter the numeric formatting of cells, set the number of digits to be displayed, as well as specify the characters used as separators and indicators for negative numbers, for data displayed using this transform method. To set the default display for other transform types, you may change the Data displayed as dropdown menu.
You may also choose the default Text justification and Indentation for alphanumeric display.
We emphasize the fact that these display options only apply to newly created series or group objects. If you subsequently alter the defaults, existing objects will continue to use their own settings.
Table Options
The table options section contains options for copying tables.
You may, by default, copy in text, LaTex or HTML formats. Number may be copied as depicted, or at highest resolution. Table headers may be copied or not, and you may show or suppress the copy options dialog each time you perform a copy.
Workfile Storage Defaults
The Workfile Save dialog in the Data storage section allows you to specify storage precision and compression options for your saved workfiles, and to specify whether to create backup workfiles when overwriting existing files on disk.
The Series storage portion of the dialog controls whether series data are stored in saved workfiles in single or double precision. Note that workfiles saved in single precision will be converted to double precision when they are loaded into memory.
In addition, you may elect to save your workfiles in compressed format on disk by checking the Use compression setting. Note that compressed files are not readable by versions of EViews prior to 5.0, and that they do not save memory when using the workfile, as it is uncompressed when loaded into memory. Compressed workfiles do, however, save disk space.
You should uncheck the Prompt on each Save checkbox to suppress the workfile save dialog on each workfile save.
In addition, you may specify whether EViews should keep backup copies of workfiles when saving over an existing file. If selected, the automatic backup copy will have the same name as the file, but with the first character in the extension changed to “~”.
Database Storage Defaults
You may also control the default behavior of EViews when moving data into and out of databases using the Database Store and Database Fetch dialogs within the Data storage section. These dialogs control the behavior of group store and fetch (see “Storing a Group Object” and “Fetching a Group Object”), and whether data are stored to databases in single or double precision.
Date Representation
The Date representation dialog controls the format for dates in sample processing, and in workfile and various object views. For daily and weekly data, you can set the default to American (Month/Day/Year) or you may switch to European notation (Day/Month/Year), where the day precedes the month. You may also specify your quarterly or monthly date display to use the Colon delimiter or a Frequency delimiter character based on the workfile frequency (“q” or “m”). The latter has the advantage of displaying dates using an informative delimiter (“1990q1” vs. “1990:1”).
See also “Free-format Conversion Details”for related discussion.
Estimation Defaults
You can set the global defaults for the maximum number of iterations, convergence criterion, and methods for computing derivatives in the Estimation options dialog.
These settings will be used as the default settings in iterative estimation methods for equation, log likelihood, state space, and system objects. Note that previously estimated EViews objects that were estimated with the previous default settings will be unchanged, unless reestimated. See “Setting Estimation Options” for additional details.
When the Display settings option is checked, EViews will produce additional output in the estimation output describing the settings under which estimation was performed.
Programs
The first page of the Programs section provides some general options for running EViews programs. You can stop a program from running after exceeding a specified number of errors by entering the error count in Maximum allowable errors before halting.
You may also use this dialog to specify whether EViews should keep backup copies of program files when saving over an existing file. The backup copy will have the same name as the file, but with the first character in the extension changed to “~”.
If the checkbox labeled Version 4 compatible variable substitution is selected, EViews will use the variable substitution behavior found in EViews 4 and earlier versions. EViews 5 changed the way that substitution variables are evaluated in expressions. You may use this checkbox to use Version 4 substitution rules. See “Version 4 Compatibility Notes”for additional discussion.
In addition, you may modify the Display Settings to change the display of text and editing behavior in program files.
If Use syntax coloring is selected, basic programming keywords, strings, and comments will be displayed in color. You may also Enable word wrap and Display line numbers in programs.
The two controls on the right-hand side determine auto-indenting and tab size settings. The Tab size (in spaces) edit box lets you set how many characters a tab will use in the program editor. The Indent dropdown lets you specify the type of automatic indenting that the program editor will use. Auto on means that EViews will attempt to automatically apply a single tab for lines of code that are inside a program statement (“For/Next”, “If/Endif”, “While/Wend”), or inside a subroutine. Note that the single tab will be applied on top of any tabbing that was already in place. Auto on w/completion means that EViews will apply automatic indenting, and will also automatically close any program statement. For example, EViews will automatically add “Next” to the start of the next line when you finish a line starting with “For”. Auto off means no automatic indenting will be employed.
The Runtime settings dialog in the Programs section specifies whether, by default, EViews runs programs in Verbose mode, listing commands in the status line as they are executed, or whether it uses Quiet mode, which suppresses this information. EViews will run faster in quiet mode since the status line display does not need to be updated.
This default may always be overridden from the Run Program dialog, or by using the option “q” in the run statement, as in:
run(q) myprogram
For details, see “Executing a Program”.
PDF Page Settings
The PDF page settings dialog determines default settings when you export an object as a PDF (Portable Document Format). You may set the Paper to a preset type and size, or determine your own. You may also set the default Orientation and Margins for your PDF output.
LaTex Settings
The LaTex settings section controls the default output of tables in LaTex as either tables, or images embedded in LaTeX commands. In addition, you can specify a directory in which the images should be stored, and instruct EViews to put the LaTeX input command on the clipboard so it may easily be used in your documents. You may also set the default for whether or not to include a full LaTeX document specification in your output.
External Program Interface
The External program interface entry allows you to specify the default case to use when creating destination objects in MATLAB or R using the xput command. The defaults may be overridden by specifying the “case=lower” or “case=upper” option in the xopen command or by specifying an explicit destination name using the “name=” option in the xput command.
You may also use the COM ProgID section of the dialog to specify the default Programmatic IDs (ProgIDs) used when instantiating a MATLAB or R COM server. The ProgID is used to indicate the version of MATLAB or statconnDCOM to which EViews connects when you issue an xopen command. Each dropdown will contain values found in the Windows registry on your system that were entered when you installed MATLAB and statconnDCOM. You may choose from entries in the dropdowns, or type in a specific ProgID for EViews to use when opening a MATLAB or R session. The default settings may be overridden by specifying “progid=” in the xopen command.
For details on these settings see xopen and xput.
Network Proxy Server
Some EViews features (such as automatic update, registration) require internet access. If internet access is only available on your network via a proxy server, you may provide EViews will your proxy server settings.
Simply click on Network proxy server to display the relevant dialog and enter your settings. You may click on the Auto detect button to have EViews try to determine your settings for you. Note that valid proxy server setting values generally take the form:
servername:8080
where servername represents the name (or IP address) of the proxy server and 8080 is replaced by the actual port number be employed.
If Microsoft Internet Explorer has previously setup properly with a proxy server on the current machine, you can click the Auto detect from IE button to import the current settings into EViews.
EViews is only concerned with HTTP and HTTPS access. For a single proxy server that supports both protocols, enter the server name and port number into the HTTP edit field.
If a different server is used for HTTPS, uncheck the Use the same proxy server checkbox and enter the server name and port number into the HTTPS edit field.
For a proxy server that requires username/password authentication, enter the information into the Proxy Authentication fields.
Click the Test Internet Access button to test these settings on your local network.
File Locations
This selection allows you to set the default working directory, and the locations of the .INI file, database registry and alias map, and the temp directory.
The dialog also reports, but does not allow you to alter, the location of your EViews executable.
Note that the default working directory may also be changed via the File Open and File Save or File Save As dialogs, or by using the cd command.
Advanced System Options
You may use the Advanced system options dialog to set memory allocation and expression evaluation options. Unless there is a specific reason for changing settings, we strongly recommend that you use the default EViews settings.
Memory Allocation
The top portion of the dialog allows you to adjust the EViews memory allocation settings.
By default, for 32-bit machines, EViews allows a maximum of 4 million observations per series. You may use the dropdown menu to increase or decrease this limit. If you using the 64-bit version of EViews, this control will not appear, and you will be limited to 120 million observations per series.
The total memory available for all EViews objects is limited by the maximum address space per application. Standard Windows XP systems allow for 2GB of address space, but may be configured to use 3GB (using the /3GB switch). Windows XP x64 systems allow for 4GB of address space per application. The amount of available address space in 64-bit versions of Windows will depend on the specific version. Note that if the amount of physical memory available is less than the address space in use, available disk space will be used as virtual memory, which will significantly degrade performance.
EViews reserves a portion of this address space for auxiliary purposes. This memory is used by the operating system, DLLs, external database drivers, and by EViews when creating objects. Reducing the size of the reserved space will increase the amount of address space available for holding observations, but will decrease the total number of objects allowed in EViews, and may lead to instability caused by out-of-memory conditions.
By default, EViews increases the speed of evaluation by first compiling expressions to machine code. The pre-compiled code executes more rapidly, but the compilation procedure and evaluation requires additional memory. You may uncheck this setting to use the slower, memory efficient method of evaluation.
Multi-Processor Use
The Multi-processor/Multi-core use section may be used to define the maximum number of threads you would like to allow EViews to use when processing statistical calculations. EViews treats processors and cores symmetrically, and does not include hyper-threaded processors. In general, we recommend leaving this setting at Auto.
When set to Auto, EViews detects the number of cores in your system and attempts to use all of them. You may override this setting for up to eight threads. This allows you to increase the number of threads EViews uses to beyond the physical number of cores. We have not found this to be effective, but, in principle, it could improve performance with hyper-threading. If you require more processing power for other applications, you may wish to limit the number of threads EViews uses by setting this number below the physical number of cores. This is guaranteed to work with Intel processors, and, to our knowledge, should work with other brands of processors as well.
You may click on the Reset to EViews Defaults button to return to the default settings.
Graphics Defaults
These options control how a graph appears when it is first created. The great majority of these options are explained in considerable detail in “Graph Options”.
Additional dialog pages are provided for specifying the default settings for use when saving graphs to file (Exporting) and for handling sample breaks, missing values, and panel data structures (Samples & Panel Data).
Default settings for color and background transparency may be set in the Frame & Size/Color & Border entry of the Graph Options dialog.
The Quick fonts section lets you set multiple graph font settings all at once. You can change the font face, style and size for all axes, legends, text objects and observation labels in a single step.
See “Basic Customization” and “Graph Objects”.
Database Registry
The Database Registry settings are described in detail in “The Database Registry”.
Cloud Management
The Cloud Management settings are described in “Cloud Drive Support”.
EViews Auto-Update from Web
IHS Global Inc. occasionally releases patches to the EViews program, and we strongly recommend that you keep your copy of EViews as up-to-date as possible.
EViews includes an automatic updating feature that can check for new updates automatically, and install any update that may be available. The automatic update feature can be disabled from the Options/EViews Auto-Update from Web item in your main EViews menu. You can also manually check for updates from within EViews at any time by selecting Check now... under the EViews Auto-Update from Web menu item, or by selecting EViews Update from the Help menu.
You may also check for updates to the EViews program or for updates to supplementary components such as the EViews documentation or sample data and programs, by visiting the Download section of the EViews website (www.eviews.com).