Compatibility Issues with OSX 10.15 'Catalina'

All current EViews Mac versions will not run properly on the new version of OSX v10.15, codenamed 'Catalina'.

However, we are testing a beta release for the free Student Version Lite only. If you have upgraded to Catalina and want to use our beta Student Version Lite, please proceed to request a Student Version Lite license with the understanding this is still a beta test.

We do NOT have a beta test for the paid Univesity Edition. We are actively working on a new compatible version and we hope to release it sometime soon. Until then, we ask our Mac customers to delay upgrading to OSX 10.15. Please check back with this web page for status updates.

If you can't delay upgrading, or if you've already upgraded, then the only other solution is to use our Windows version. Please feel free to register your serial number onto a Windows machine (or virtual machine). When we release an updated Mac version, you can then reach out to us to switch over your serial registration back to your Mac.

Thank you for your patience and understanding in this matter.

If you have questions or concerns about this, please email us at support@eviews.com along with your serial number.

The EViews Team